Details
-
Type: Bug
-
Status: Open
-
Priority: Trivial
-
Resolution: Unresolved
-
Affects Version/s: 4.7
-
Fix Version/s: Unscheduled
-
Component/s: None
-
Labels:
-
Versioning Impact:Patch (backwards-compatible bug fixes)
-
Documentation Required?:None
-
Funding Source:Needs Funding
Description
We have an old syntax in use for the cancel recurring. Ideally we want to change FROM
$paymentObject->isSupported()
to
$paymentObject->supports()
and remove the isSupported method entirely.
We also want to change
$paymentObject->cancelRecurring(string, array)
{ return something odd; }to
$paymentObject->doCancelRecurring(array)
{ return array or throw exception; }Once again for consistency with other methods
I'll note the similar desired changes for editRecurring shortly - but these also include allowing the processor to specify editable fields - e.g IATS, eway would permit editing next_sched_contribution_date
$paymentObject