Uploaded image for project: 'CiviCRM'
  1. CiviCRM
  2. CRM-1903

Cannot see any custom field groups when creating new Profile


    • Type: Bug
    • Status: Done/Fixed
    • Priority: Major
    • Resolution: Won't Fix
    • Affects Version/s: 1.7
    • Fix Version/s: None
    • Component/s: Core CiviCRM
    • Labels:


      I am running CiviCRM 1.7 9379 with PHP4 and Drupal 5.1.

      In order to set up CiviContribute's custom field features, there needs to be a CiviCRM Profile created with the Custom Field groups you want included. In my case, these were already there from my 1.6 database.

      Although everything appears set right, when I load the contributions page the datatypes are all worng in the form. What should be a radio button shows up as a date. If I try and make a new profile, when I select "Contributions" from the field type drop down, I do not see my custom field groups. Likewise, I tried making a custom field group for Individuals and that doesn't show up in the Profile edit form either!

      Steps to reproduce: (NOTE - I tried these on the demo CiviCRM 9467 and it works... too bad it won't work for me in php4 )
      1. Stage a fresh 9379-php4-drupal with empty DB
      2. Administer CiviCRM >> Enable components - turn on CiviContribute
      3. Administer CiviCRM >> Custom Data - click New Group of Custom Fields
      4. put in "test" as the group name, set Used for to be "Contributions", "-Any-", then hit Save
      5. Click "View and edit custom fields" next to "test". Add a custom field to it. Use the default of a text box and put in the field label: "What do you think of CiviCRM?"
      6. go to Administer CiviCRM, then under Configure, "CiviCRM Profiles"
      7. Click "New CiviCRM Profile", name it "test-profile" and hit Save
      8. Click "View and Edit Fields" next to "test-profile" and click the "add one now" link to add one
      9. Under "Field Type" choose "Contributions" from the left drop down.
      10. Now look in the right drop down. It contains the normal contributions field. It should also contain "What do you think of CiviCRM?" but it does not.

      • When I perform these steps on the 9467 demo.civicrm.org instance, the question shows up. If you visit that demo instance now you should see my profile containing one, it is named "test-contribute".

      Please help! I tried looking for bugs resembling this in the SVN commits but could not spot what would have fixed it since 9379 release and that demo.




            • Assignee:
              dgg David Greenberg
              damien_vancouver Damien Norris
            • Votes:
              0 Vote for this issue
              1 Start watching this issue


              • Created: