Uploaded image for project: 'CiviCRM'
  1. CiviCRM
  2. CRM-9034 Fixes for many strict PHP warnings.
  3. CRM-9550

Correct CRM_Admin_Page_MessageTemplates::action() and browse() function signatures.

    Details

    • Type: Sub-task
    • Status: Closed
    • Priority: Trivial
    • Resolution: Fixed/Completed
    • Affects Version/s: 4.2.0
    • Fix Version/s: 4.2.0
    • Component/s: Core CiviCRM
    • Labels:
      None

      Description

      The attached patch resolves the following php warning notice:
      Strict warning: Declaration of CRM_Admin_Page_MessageTemplates::browse() should be compatible with CRM_Core_Page_Basic::browse() in require_once() (line 43 of /var/www/sites/all/modules/civicrm/CRM/Admin/Page/MessageTemplates.php)

      EDIT: Replacement patch also corrects the signature for the action() function in the same file.

        Attachments

          Activity

            People

            • Assignee:
              lobo Donald A. Lobo
              Reporter:
              pillarsdotnet Bob Vincent
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: