• Type: Bug
    • Status: Done/Fixed
    • Priority: Blocker
    • Resolution: Fixed/Completed
    • Affects Version/s: 1.3
    • Fix Version/s: 1.5
    • Labels:



      I am using CivicSpace, and upgraded civicrm from 1.2 to 1.3rev4404.

      The upgrade appears to work ok, with the exception of when I am importing data. I have created custom data (Voted 2000 Primary, 2002 Primary) etc..that I have imported in the past without issue.

      Now when I go to import the data, when I get to the 3rd screen, it reports hundreds of errors. It says:

      CiviCRM has detected invalid data or formatting errors in 716 records. If you continue, these records will be skipped. OR, you can download a file with just these problem records.

      Originally, I had set up the custom fields to be yes/no. With 0/null being No, and 1 for yes.

      The first time I encountered the problem, I had set the import files with 0's for no, and 1's for yes. When I tried to import, all failed. So I removed the Zeros , and left the 1's alone. That seemed to work for the errors caused by the 0's, but did not affect the 1's,.

      So then I tried a search and replace on the 1's, changed them to 2's, and then changed them back to 1's again. Still the same thing. Then I tried checking the formating of the cells in excel. I tried general, text, and number (No decimals). No change.

      So I deleted all the custom fields, and re-created with no luck. Then I re-created them again using radio buttons instead of yes/no ( Which I actually like better).

      Still wouldn't import. There is another field thats doing the same thing, and has 1's - will not import.

      I am attaching the database error file created by civicrm for you to review, and the original cvs import file.

      The site is at

      I'll forward a login/password for you at your yahoo address.

      Please let me know if there is anything else I can do.

      Thank You!





            • Assignee:
              kurund Kurund Jalmi
              alexn Alex N
            • Votes:
              0 Vote for this issue
              0 Start watching this issue


              • Created: